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Troubleshoot password policy issues on macOS devices

This guide helps you troubleshoot password policy issues on macOS devices.

1. Issues with setting device password after updating to macOS Sonoma

Issue

When a device that has a password policy associated with it is updated to macOS Sonoma, users are asked to set a new password. After setting up the password which meets the password requirements, the device still does not accept the password.

Here are some other methods you can try,

Solution

Method 1

Attempt a device restart, then proceed to set a new password at the login page as per the password requirements.

Method 2

If the entered password is still invalid, you can also reset the password by putting the device into recovery mode. Follow the below steps to reset the password,

  1. Shut down the device.
  2. To enter recovery mode, press and hold the power button for a few seconds.
  3. In the Utilities menu, select Terminal.
  4. Type resetpassword and press enter.
  5. A window will pop up allowing you to change the passwords for the user accounts on the device.

Method 3

If the issue arises on the device containing only a single user account, create an admin account on the device by following the below steps:

  1. Log in to the Hexnode portal, go to the Manage tab.
  2. Select the required devices.
  3. Click Actions > Create User Account.
  4. Set the Account type as Administrator and configure the account settings.
  5. Click Create to create an admin account on the device.

Upon creating the admin account, log into it and reset the password of the affected user account.

                                             OR

You can also change the password of the affected user account with Hexnode, follow the below steps to change the password,

  1. Log in to the Hexnode portal and navigate to Manage > Devices.
  2. Select the macOS device whose user account(s) password you want to change.
  3. Navigate to the Local Accounts tab.
  4. Select the three-dot menu next to the desired user.
  5. From the drop-down menu, select Change Password.
  6. Enter the admin username and password under Administrator account credentials.
  7. Enter the new password and password hint for the target user under Target account details.
  8. Click Proceed and Confirm to finalize the password change.

Method 4

Remove the existing password policy associated with the device and follow the below steps:

  1. Allow the user to log in to the account.
  2. Once the user has logged in, re-associate the password policy with the device.

2. Issues with setting up the password

Issue 1:

When an administrator attempts to change the password for a user account through the Hexnode portal, they receive a failed message stating that “Mandatory fields not exist” even though they have met the necessary password requirements.

Similarly, when an administrator tries to set a password while creating a new user account through the Hexnode portal, they encounter the same error message as “Mandatory fields not exist”. This issue arises even though all necessary password requirements have been fulfilled.

Probable Cause

The issue can arise when setting the password containing special characters ¡, ™, £, ¢, ∞, §, ¶, •, ª, º, –, ≠, «, ‘, “, æ, …, ÷, ≥, ≤.

Troubleshoot password policy issues on macOS - the device shows

Solution

When setting a password using special characters, it is recommended to exclude using characters like ¡, ™, £, ¢, ∞, §, ¶, •, ª, º, –, ≠, «, ‘, “, æ, …, ÷, ≥, ≤.

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