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Troubleshoot EXE app installation issues for devices in Hexnode
This troubleshooting guide aims to help you diagnose and resolve any issues while deploying EXE apps from the Hexnode UEM console. This doc aids you in the smooth installation of EXE apps on Windows devices.
1. The installation of the app fails due to the inability to meet the specified success criteria
Description
The following error message appears on the Hexnode UEM portal when attempting to install the EXE app via the remote action.
“Unable to meet the success criteria set”
Possible cause
This error occurs when the configured Success Criteria has some mistakes in it.
Solution
To solve this, you must provide the correct Success Criteria parameters. The right way to configure the success criteria is as follows:
- For the App Exists success criterion, provide proper app identifier that can be fetched from our portal or from the device end itself.
- For the File Exists success criterion, provide the complete path to the file present on the device.
For example:The file path should be like,
C:\Hexnode\Hexnode UEM\Current\Hexnode UEM.exe
And not like
C:\Hexnode\Hexnode UEM\Current
- For Registry Exists success criterion, you need to provide the path format as follows:
If the registry key path is
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
Then, while setting up the Success Criteria, select HKLM as the root key and then type the remaining path “
SOFTWARE\Microsoft\Windows\CurrentVersion\Run
” in the Path field.
2. App doesn’t support installation at user level
Description
The Hexnode UEM portal displays an error message stating that the EXE application does not support installation at the user level.
Possible cause
The app installation action fails and leaves a message like this when the “Install app at the system level” option is unchecked. When an app is installed at the system level, it’s accessible to all users on a computer, not restricted to just one user. So, in this case, the app you have tried to install only supports system-level installation.
Solution
Execute the “Install Application” action again, ensuring that the “Install app at system level” option is enabled when configuring the app installation settings.
3. Failed to download the application on the device
Description
The Hexnode UEM portal displays an error message indicating that the application download failed on the device end.
Possible cause
This may be due to the unstable internet connection on the device end.
Solution
It is important to maintain uninterrupted internet connectivity on the device end during the deployment of EXE applications from Hexnode UEM.
4. The EXE file used is corrupted
Description
An error message displayed on the Hexnode UEM portal indicates that the EXE file used for app installation is corrupted.
Possible cause
The EXE file which was attempted to be installed is damaged or incomplete. This could be due to various reasons such as errors during download, transfer, or storage, or possibly due to a problem with the file itself.
Solution
Always use EXE files downloaded from trusted sources only. Re-initiate the installation process with the new EXE file. Also, ensure that the EXE file has been fully downloaded from the source.
5. Installation timed out. Re-initiate the action
Description
The EXE app installation status on the Hexnode UEM portal indicates that the app installation has exceeded the allowed time and has consequently timed out.
Possible cause
This error can arise in two scenarios.
Scenario 1: Silent app installation option enabled
In this scenario, the installation of the EXE application on the device end is set to occur silently, without requiring user interaction. If an incorrect command-line parameter for silent app installation is used while configuring the EXE app deployment, it can result in the failure of the app installation.
For example, if the correct parameter for silent installation is “/s”, but the user provided it as “SILENT” during the configuration of the EXE app deployment, this will cause the app installation failure.
Solution
Reconfigure the EXE app by specifying the exact parameters for silent installation, and then initiate the installation process again. This will enable the device to attempt the app installation once more, resolving issues that may have caused the installation failure.
Scenario 2: Silent app installation option disabled
In this case, the EXE app installation is set to occur with the help of user interaction. There is a chance that users may ignore the installation prompt that will appear on the device or forget to complete all the necessary steps in the installation process, resulting in app installation failure.
Solution
For user interactive app installation, select the “Install” option from the app installation prompt on the device and complete all necessary steps for the installation process without fail.
6. User had denied the app installation request
Description
The error message displays that the user has denied the app installation request. This installation request prompt will only appear if the ‘install silently’ option is unchecked while configuring the app installation.
Possible cause
This will appear if the user selects the option “Not Now” from the installation prompt on the device.
Solution
Users can grant permission to install the app even after opting for the “Not Now” option. After selecting the “Not Now” option, the app installation request will appear under the Notifications section of the Hexnode UEM app. Users can grant permission for installing the app from here.
This app installation prompt will appear under the “Notifications” section of the Hexnode UEM app only if the administrator checks the “Retry if the installation fails” option while configuring the app installation settings.