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Common errors while enrolling iOS device in Apple Business Manager
1. Invalid Profile
Description
A common error message during device activation.
Solution
Here are some possible remedies for this error:
- Make sure that you have adequate MDM Licenses to manage your devices.
- Sign in to your Hexnode UEM portal, head on to Admin > License > Total device count.
- Head on to Dashboard and check the number of enrolled devices. If the number of your enrolled devices has reached the maximum limit for your license, you need to upgrade the license to manage more devices.
- Ensure that the Server Token has not expired.
- In case the Server Token has expired,
- Sign in to your Apple Business Manager account.
- Click on the account name at the bottom of the left side panel and navigate to Preferences > choose your MDM server. Click on Download Token to download a new DEP Token from your server.
- Head on to Admin > Apple Business/School Manager > Apple DEP > DEP Accounts.
- Click on the edit icon that appears when you move the cursor to the right of the respective DEP account.
- Upload the new token in the Upload Token field and click Save.
- Verify that you have pushed the DEP Policy to your iOS device.
- You can push the DEP Policy to your iOS device(s) by signing in to your Hexnode UEM portal.
Go to Admin > Apple Business/School Manager > Apple DEP. - Select DEP Devices > Choose the required device(s) > Click the Associate DEP Profile button.
Now, you need to wipe your device to re-enroll them into your Hexnode UEM account.
- You can push the DEP Policy to your iOS device(s) by signing in to your Hexnode UEM portal.
- Check if the Pre-approved settings have been enabled in both Enrollment settings and Apple DEP settings.
On your Hexnode UEM portal,- Go to Admin > Enrollment.
- If you have enabled the option Pre-approved Devices only under Enrollment Restrictions,
- Ensure that the OS updates are not pending on any of the iOS devices that you are trying to enroll.
In case there are pending OS updates, you need to remove the required devices from your Apple Business Manager account before executing the OS update.- Go to Apple Business Manager and sign in to your account.
- Click Devices. Search and select the required devices from the list. You can filter devices based on their source, order numbers, device types, etc.
- Next, click on the database icon.
- Select the Unassign option to unassign devices from the MDM server.
- After unbinding the device from the MDM server, complete the pending OS updates on your iOS device.
- Go back to your Apple Business Manager account and re-assign the devices to the MDM server.
- Now, sign in to your Hexnode UEM portal and navigate to Admin > Apple Business/School Manager > Apple DEP > DEP Devices > Click the Sync with DEP button.
2. Even after successful sync, the device does not get listed on the DEP Devices page on the Hexnode portal.
Solution
Perform the following methods to resolve this syncing issue:
- Check whether the DEP token is expired. Renew the DEP token, and then factory reset the devices.
- If the DEP token is not expired, ensure that any new terms and conditions released by Apple are accepted from the ABM portal. If Apple’s terms are not accepted, renew the token again (even if the token is still valid) and accept the conditions. Now, perform the sync action again.
- Ensure that you have not enrolled the device in the MDM server using an enrollment method other than DEP. If any other method is used, remove the device from management and reset your device to factory settings. From your Hexnode UEM portal, go to Admin > Apple Business/School Manager > select Apple DEP > click the Sync with DEP button.
3. The configuration for your iPhone/iPad could not be downloaded. The configuration is not available
Description
Error message during device activation.
Solution
- Check your network connectivity.
- Additionally, check if the MDM server is reachable from another device in the same network.
4. Cancelled
Description
Error message during device activation.
Solution
- Check your network connectivity.
- Try restoring the device. Restoring a device reloads the configurations into it. Then, try re-enrolling the device after restoring it successfully.
5. A server with the specified hostname could not be found.
Description
Error message during device activation.
Solution
- Check your network connectivity and try again.
6. NOT_ACCESSIBLE.
Description
Error message while adding devices to the DEP portal.
Probable Cause
This error befalls if the device is either not eligible for ABM enrollment or is already enrolled by another organization.
Solution
- Check if the device is eligible for DEP enrollment. If not, enroll the device via Apple Configurator.
- Ensure that the device is not already enrolled or maintained by another organization.
7. Unable to view the MDM servers tab after signing into the ABM portal.
Solution
- Make sure that you log in to ABM with an account with either Administrator or Device Enrolment Manager roles. To assign such roles in ABM, sign in to Apple Business Manager with an account that has the role of Administrator or People Manager. Then, select Roles under People and edit/add the required roles for the respective users.
- Also, ensure that the admin has agreed to Apple’s terms and conditions.