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Troubleshoot issues on Android Enterprise devices enrolled via Google Workspace
1. “Account action required” error on Google Workspace enrolled devices.
Description
On Android devices enrolled in Google Workspace (G-Suite), attempting to open Google apps causes a redirection to the Hexnode UEM homepage, displaying an “Account action required” error notification.
Possible Cause
This issue may occur when the Google Workspace admin account used for device enrollment is removed from the device.
Solution
To continue using Google services, make sure you have the same Google Workspace admin account on the device used for enrollment. If you delete it and add another account, you might have trouble accessing Google services.
To use an account other than the Google Workspace admin account, it is suggested to reset the device and enroll it using the desired account. By doing this, all Google services will be accessible without any issues.
2. Accessing purchased apps and content: Issues after switching from Google Workspace to Gmail account.
Description
When attempting to switch the primary Google account on an Android device from a Google Workspace account to a Gmail account, access to purchased apps and content associated with the Google Workspace account is blocked.
Solution
The apps and content purchased from the Google Play store are linked to the primary Google Workspace account on the device. If you switch your primary account to a Gmail account, the purchased apps and content tied to the original Workspace account may not be accessible under the new account added. To retain access to previously purchased content, it is recommended to keep the Google Workspace account as the primary account on the device or consider using both accounts simultaneously. Unfortunately, there might not be a direct workaround to transfer purchased content between Google accounts.
3. Unable to remove the work profile on Google Workspace enrolled devices through “Android Enterprise Work Profile on Company-owned devices (WP-C)”.
Description
On Android devices enrolled via WP-C, the option to remove the work profile is greyed out.
Solution
By enrolling devices in WP-C, a dedicated work profile is created that effectively separates work-related data from personal information. Removing the work profile from the device end cannot be accomplished independently; it can only be done by resetting the device.