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Common errors while enrolling iOS devices using Apple Configurator
1. This iPhone/iPad is supervised by another computer and cannot be used with this computer.
Description
Error message while connecting a managed iOS device into a computer.
Probable Cause
You might have disabled iTunes Pairing from your Hexnode MDM portal. Disabling this option will block every iTunes-related action.
Solution
- After signing in to your Hexnode MDM portal, head on to Admin > Apple Business/School Manager > Apple DEP.
- Select DEP Configuration Profiles > Open the DEP Profile associated with the device.
- Check the option Allow iTunes Pairing > scroll down and click Save.
- After saving the policy, your device needs to be wiped and re-enrolled for the policy to be in effect.
2. NSURLErrorDomain – 1012
Description
Error message while enrolling a new device to Hexnode UEM using Apple Configurator.
Probable Cause
This error befalls when Apple Configurator has cached an expired certificate.
Solution
- From the Apple Configurator 2 menu, choose Preferences.
- Select the Servers tab.
- Choose the required Hexnode MDM server and delete it by clicking the “-” button at the bottom of the window.
- Now, try to re-enroll your device.
Select the required Blueprint in Apple Configurator > click Prepare and follow the prompts.
This process makes Apple Configurator retrieve the latest Hexnode MDM certificates and may resolve the error.
3. An unexpected error has occurred with iPad.
Description
Error message on Apple Configurator 2.
Probable Cause
This error typically occurs when you connect your device to a Wi-Fi network before starting the Apple Configurator enrollment process.
Solution
- On your iPad setup settings, Choose a Wi-Fi Network > select the required Wi-Fi network > click Next and follow the prompts until you get to Location Service.
- Now, go to Apple Configurator 2 and prepare the iPad once more.
- On your iPad, if you cannot connect to a network, go back to Choose a Wi-Fi Network > select a Wi-Fi network > click Next and follow the prompts appropriately so that the device gets supervised.
4. An unexpected error has occurred: The device returned an unexpected status. (CommandFormatError)[com.apple.configurator.MobileDeviceKit.error]
Probable Cause
This error may occur when you try to update to iOS 11 along while trying to enroll with Apple DEP.
Solution
Make sure that you complete updating the device to iOS 11 before adding the device to DEP.
5. A cloud configuration is already present on this device.
Description
Error message during device activation.
Solution
- Make sure you turn Off Find my iPhone/iPad.
- Connect your iOS device back to Apple Configurator.
- Right-click the device > select Restore.
On your device, go to Settings > tap your name > iCloud > swipe the Find My iPhone button to Off.
This process re-downloads iOS into your device and probably fixes the problem.
6. Unable to verify the server’s enrollment URL.
Description
Error message while preparing the devices in Apple Configurator.
Solutions
-
You can verify your Enrollment URL by logging into your Hexnode MDM portal.
Go to Admin > Configurator Enrollment > Choose Default User > Save the settings and retry the enrollment process.
- Ensure that you have enough licenses available for your subscription. You can obtain the total device count permitted for enrollment by navigating to Admin > License. The actual number of enrolled devices is displayed on the Hexnode MDM dashboard as ‘Enrolled Devices’.
- Check if you have configured the APNs certificate on the portal and the certificate is valid.
7. Unable to skip the step for entering the Apple ID and password while configuring the blueprint.
Solution
While setting up the blueprint, uncheck the option Add to Apple School Manager or Apple Business Manager so that you can skip the step asking for Apple credentials.
8. The screen gets unresponsive on fetching Anchor Certificates while configuring the blueprint.
Solution
Click on Next as this step does not affect the blueprint creation.
9. An unexpected error has occurred with “iPhone”.
Description
Error message while preparing the device in Apple Configurator.
Probable Cause
This error may sometimes happen if:
- You use Apple Configurator to enroll different types of devices successively.
- The device is already prepared with Apple Configurator.
Solution
Update Apple Configurator 2 to the latest version to remediate this issue.
10. An unexpected error has occurred with “iPhone”. The device is not connected
Description
Error message while preparing the devices in Apple Configurator.
Probable Cause
This error happens when the device disconnects while preparing it with Apple Configurator.
Solution
Make sure that the cable connection at the device or Mac has not become loose or unplugged.
11. Unable to find the supervision identity for the organization “_________”
Description
Error message while preparing the devices in Apple Configurator.
Probable Cause
Apple Configurator cannot verify the supervision identity as the private key for the organization’s identity is no longer available in the Keychain.
Solution
Repair or delete the organization from Preferences > Organizations from the Apple Configurator menu. Note that the connected device features will be disabled.